AllEvents ( Starter )

For Individuals, Bloggers, Associations, Small Agencies. Download & test our component.


Extension: Component
Version: 3.5
Type: FREE
Compatibility: 3.7.*

Extended Component
Extension for various modules and plugins

  • No limits for Events
  • No limits for Calendars
  • No limits for Venues
  • No limits for Enrolments
  • No limits for Resources
  • No limits for Publics
  • No limits for Sections
  • Enrolments
  • Module Calendar with default
  • Module List with default layout
  • Module Banner
  • Module Deck
  • Module Slider
  • Modules FullCalendar
  • Plugin Quickicon
  • Plugin Search
  • Plugin Content
  • Plugin Finder
  • Plugin Social (G+, Twitter, social, FB)
  • Plugins Third party (Acymailing, CB USers, Jcomments)
  • Plugin Vote (Vote, Rating)
  • Plugin Phocadownload
  • Plugins payments (paypal,...)

Key Features

  • Beautiful frontend : AllEvents blends seamlessly into the template of your website. It also comes with various Menu Item Types like a list, table, calendar, map.
  • Event management
  • Calendar management
  • Venue management : this feature you can Manage Venues and link your Events to the Venue. This will allow central management of all Venues & Address data making the event creation form shorter and simpler. The Venue creation is very wimple with the with Google Maps AdressPicker.
  • Events Providers: Different sources like AllEvents, Google Calendar (only read), Icalendar files (only read or import)
  • Layouts: Various layout parameters
  • Responsive: Responsive layout and design (HTML5 and CSS3)
  • Advanced permissions: AlLEvents supports the Joomla permission system. You can define add, edit, delete, enrol, … permissions for events.
  • Event Specific Fields: From Joomla 3.7, you can define your own fields in your event with the Joomla custom fields.
  • Technical social: Micro Data Rich Snippets, Open Graph Tag, Twitter cards are supported in AllEvents for your events
  • Multiple Payment Options: AllEvents is powered by the 'Joomla Common Payments API’ . Your Subscription comes with free support and updates for the following plugins (Paypal, Paypal – Adaptive Payment, Authorizenet, 2Checkout, Pay By Check, Pay By Purchase Order, Alpha User Points, JomSocial Points)

Requirements

AllEvents is a Joomla extension, so you need to have a website built on Joomla CMS to use the extension. Please look at https://www.joomla.org/about-joomla/technical-requirements.html to see technial requirement for your server. AllEvents only works with Joomla 3.6+, it doesn’t work with Joomla 1.5 and Joomla 2.5.

Beside generic requirement with a Joomla website, AllEvents also requires some additional requirements below:

  • PHP 5.5.x+. Joomla 3.6 requires PHP 5.3.10+ already, so if you are using Joomla 3, you won’t have to worry about this requirement. However, if you are using Joomla 2.5, make sure your server is running PHP 5.3.x+ (on some Joomla 2.5 websites, we still see the server running PHP 5.2.17). If that’s the case with your site, please contact your hosting provider, ask them to change settings for your hosting account to use Joomla 5.3.x+.

  • Compatible Browsers: Firefox, Chrome, Safari, IE8+, Opera.
  • If you use a credit card based payment plugin (for example, Paypal Pro, Authorize.net, Eway, NAB Transact…), customers will enter credit card information directly on your site for processing payment, so your site should have an SSL certificate installed so that the payment process will be secure. Without an SSL certificate, AllEvents still works well, however, in this case, the credit card data which customers enter on your site for processing payment won’t be encrypted when it is transfered over internet, and it will be inscure.

Our Technologies

JavaScript logo
CSS 3 logo
HTML 5 logo
UI Kit
GitHub

Don't Miss This Great Opportunity!